Payment Processing Outage in NY

Incident Report for Forage

Resolved

This incident has been resolved.
Posted Aug 19, 2026 - 09:28 UTC

Update

We are continuing to investigate this issue.
Posted Aug 19, 2026 - 08:53 UTC

Update

We are continuing to investigate this issue.
Posted Aug 19, 2026 - 08:24 UTC

Investigating

We are currently investigating a processing outage affecting cardholders in NY.
Posted Aug 19, 2026 - 08:22 UTC
This incident affected: State Processors.