The incident affecting payment processing in the states - AR, CT, DE, GA, IA, IL, IN, LA, MA, ME, MD, MI, MS, NH, NJ, NY, OH, OK, PA, RI, SC, TN, UT, VT, VA is now resolved.
Posted Apr 27, 2025 - 22:24 UTC
Update
We have not seen any denial errors in the past hour. The state processor is still monitoring the situation, as there has been higher-than-normal latency on some of their requests.
Posted Apr 27, 2025 - 21:27 UTC
Monitoring
We are starting to see successful transactions in states that previously had issues. We will continue to monitor until we receive communication from the state processor.
Posted Apr 27, 2025 - 19:00 UTC
Update
We are currently in contact with the state processor, who has acknowledged the issue. They are actively working on a resolution. At this time, there is no estimated time for recovery. We will continue to monitor and provide updates as soon as more information becomes available.
Posted Apr 27, 2025 - 13:21 UTC
Investigating
We are currently investigating a payment processing outage impacting all cardholders in AR, CT, DE, GA, IA, IL, IN, LA, MA, ME, MD, MI, MS, NH, NJ, NY, OH, OK, PA, RI, SC, TN, UT, VT, VA.
Posted Apr 27, 2025 - 12:34 UTC
This incident affected: EBT Transaction Processing (State Processing).