The scheduled maintenance has been completed. All Maine EBT processing is now operational.
Posted Jul 27, 2025 - 12:27 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 27, 2025 - 04:00 UTC
Scheduled
From 11 PM CT on Saturday July 26 through the morning of Sunday July 27, Maine will be switching their statewide EBT processor. During this time, all Maine EBT processing will be temporarily unavailable, and no EBT purchases—online or in person—will be possible.
Please check back here for updates on when the transition is complete and EBT transactions in Maine can resume.
Posted Jul 26, 2025 - 20:44 UTC
This scheduled maintenance affected: State Processors.