Payment Processing Outage in NJ, GA, OK, MD, OH, VA, PA, CT

Incident Report for Forage

Resolved

The issue impacting cardholders in NJ, GA, OK, MD, OH, VA, PA, CT appears to be resolved. Affected cardholders had issues accessing our platform between 3:00 UTC and 3:30 UTC.
Posted Oct 17, 2025 - 03:46 UTC

Investigating

We are currently investigating a processing outage affecting cardholders in NJ, GA, OK, MD, OH, VA, PA, CT.
Posted Oct 17, 2025 - 03:19 UTC
This incident affected: State Processors.