Payment Processing Outage in MA

Incident Report for Forage

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 04:15 UTC

Investigating

We are currently investigating a payment processing outage impacting all cardholders in MA.
Posted Mar 18, 2025 - 02:28 UTC
This incident affected: EBT Transaction Processing (Online EBT, In-store EBT).