Payment Processing Outage in MD, PA, NJ, GA, OH, VA, TN, CT, IA, IN, OK, DE, AL, SC, MS, UT, AR, ME

Incident Report for Forage

Resolved

The outage was resolved at 9:32 UTC
Posted Jun 19, 2025 - 13:56 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 19, 2025 - 07:32 UTC

Identified

We have escalated with the state processor and are awaiting a response.
Posted Jun 19, 2025 - 07:28 UTC

Investigating

We are currently investigating an EBT processing outage affecting cardholders in MD, PA, NJ, GA, OH, VA, TN, CT, IA, IN, OK, DE, AL, SC, MS, UT, AR, ME
Posted Jun 19, 2025 - 07:27 UTC
This incident affected: EBT Transaction Processing (Online EBT, State Processing) and Hosted Checkout.