Payment Fraud Incident in RI

Incident Report for Forage

Resolved

This incident appears to be fraud-related and does not represent a genuine outage.
Posted Apr 01, 2025 - 05:12 UTC

Investigating

We are currently investigating a payment processing outage impacting all cardholders in RI.
Posted Apr 01, 2025 - 04:51 UTC
This incident affected: EBT Transaction Processing (Online EBT, In-store EBT).