Louisiana EBT SNAP Outage

Incident Report for Forage

Resolved

This incident has been resolved.
Posted May 29, 2026 - 02:53 UTC

Monitoring

We are currently investigating a processing outage affecting cardholders in Louisiana.
Posted May 29, 2026 - 02:25 UTC
This incident affected: State Processors.