Payment Processing Outage in CT

Incident Report for Forage

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 18:45 UTC

Investigating

We are currently investigating a processing outage affecting cardholders in CT
Posted Feb 04, 2026 - 18:02 UTC
This incident affected: State Processors.