Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 23, 2026 - 07:00 UTC
Scheduled
Forage will be executing necessary maintenance on our data storage infrastructure to improve our security and reliability. Downtime of Forage’s Platform is expected during this maintenance period.
Posted Mar 13, 2026 - 22:04 UTC
This scheduled maintenance affected: Forage Checkout API, Management Portal, and Shopify Apps.