EBT network is down
Incident Report for Forage
Resolved
This incident has been resolved.
Posted Mar 03, 2023 - 15:50 UTC
Investigating
We are currently investigating this issue.
Posted Mar 02, 2023 - 23:25 UTC
This incident affected: EBT Transaction Processing (Online EBT).