Payment Processing Outage in AL, AR, CT, DE, GA, IA, IN, MD, MS, NJ, OH, OK, PA, SC, TN, UT, VA

Incident Report for Forage

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 07:25 UTC

Monitoring

EBT processor is performing maintenance. The processor predicts downtime will continue until 05:00 UTC, however, have given a window for maintenance that extends to 12:00 UTC.
Posted Feb 18, 2026 - 04:47 UTC

Investigating

We are currently investigating a processing outage affecting cardholders in AL, AR, CT, DE, GA, IA, IN, MD, MS, NJ, OH, OK, PA, SC, TN, UT, VA.
Posted Feb 18, 2026 - 04:42 UTC
This incident affected: State Processors.