The incident affecting refund attempts in the state of MA is now resolved. Refunds in the state of MA between 2025-04-23 23:43:00 UTC and 2025-04-24 19:35:00 UTC were affected
We continue to monitor the situation.
Posted Apr 24, 2025 - 20:33 UTC
Investigating
There is an incident affecting refund attempts in the state of MA, in advance of its upcoming processor transition. We are investigating this now and will follow up with you as soon as we have more details.
Posted Apr 24, 2025 - 15:40 UTC
This incident affected: EBT Transaction Processing (Online EBT, In-store EBT).