Payment Processing Outage in MA

Incident Report for Forage

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 00:34 UTC

Investigating

We are currently investigating a payment processing outage impacting all cardholders in MA
Posted Mar 17, 2025 - 23:40 UTC
This incident affected: EBT Transaction Processing (Online EBT, In-store EBT).