Payment Processing Outage in MD

Incident Report for Forage

Resolved

This incident has been resolved.
Posted Feb 21, 2026 - 10:25 UTC

Monitoring

Approval rates have recovered
Posted Feb 21, 2026 - 10:06 UTC

Investigating

We are currently investigating a processing outage affecting cardholders in MD
Posted Feb 21, 2026 - 09:48 UTC
This incident affected: State Processors.