Payment Processing Outage in Specific States

Incident Report for Forage

Resolved

This incident has been resolved.
Posted Mar 13, 2025 - 13:22 UTC

Investigating

We are currently investigating a payment processing outage impacting all cardholders in AR, CN, DE, GA, IL, IN, IO, LA, ME, MD, MA, MI, MS, NH, NJ, NY, OH, OK, PA, RI, SC, TE, UT, VT, VA
Posted Mar 13, 2025 - 12:22 UTC
This incident affected: EBT Transaction Processing (Online EBT, In-store EBT, State Processing) and Hosted Checkout.